{February 6, 2010}   s/Activity/Context/

So… I brought up activities on plasma-devel again the other day. One of the reasons for this was that I noticed the word being used in a few different ways – mainly by me – and wanted to clear up confusion.

Well, it turns out I was the source of that confusion. :) What I’ve been referring to as “Activities” should actually be called “Context”. That’s what aaron was calling it, months and months ago, and somehow I remembered the word as something completely different and was avoiding it. Oops. So, when you read my old blog post or see my presentation from campkde, just replace 99% of the times I say “activity” with “context”.

Some other good things came of that discussion, but I have several essays to write so I don’t feel up to doing a long blog post on top of it all; either I’ll blog next week, or after we’ve discussed it at tokamak. :)

So, just to be extra clear: an Activity is a group of widgets on your desktop (what developers call a desktop containment). Context is all the stuff you need for what you’re doing right now (windows, files, etc). And if you only have one monitor, chances are you’ll have one Activity per Context anyways.

[Edit: the naming changed again (at tokamak 4, iirc). so this post is wrong now :) ]

> Activity is a group of widgets on your desktop (what developers call a desktop containment).

Then why can’t we just call it a containment? Different terms for developers and users suck. (This also applies to the silly overloaded “widgets” term which means something completely different for a user than for a developer. We should only use “widget” for a QWidget or equivalent. Plasmoids should be called applets (as in the code) or plasmoids, not widgets.) It leads to users asking questions in help channels which the developers don’t understand and the users then not understanding the answers from the developers either.

Chani says:

well, *technically*, it’s not just any containment. it’s a containment that acts as your desktop background – unlike panels, which are a different sort of containment.

I’m not 100% happy with the vocabulary either… widget/applet and plasmoid are different things as well, though, and in that case we call them “widgets” because that was the dominant term out in the intarwebs already (Applet is the class name in libplasma and as such can’t be changed before KDE 5).

roughly speaking, Plasmoids and Google Gadgets are two types of Widget; Activity and Panel are two types of Containment.

shamaz says:

If the plasma core developpers are not sure of how to interpret activities/context/whatever… Don’t expect that users will understand :/

Chani says:

well, this is a part of free software – you get to see us discussing things that aren’t finished, when we’re still in the process of finding a consensus and our ideas aren’t all implemented… it’s messy at times. :)

however, once we do get this sorted out it’ll be important to communicate clearly to users with the release. I haven’t really paid attention to the release process myself; maybe I should do up some screencasts for 4.5 or something :)

slashdevdsp says:

this might spark an idea for the activities :)

and there is a video too

Chani says:

actually that looks verrry similar to plasma ideas – I saw it just after reading one of *our* old techbase pages, which was also from 2008, and the similarities were… uhm… striking.
maybe it’s just coincidence. *shrug*

Comments are closed.

et cetera
%d bloggers like this: